
MS Word: 

Microsoft Office Word  allows you to create and edit personal and business 

documents, such as letters, reports, invoices, emails and books. By default, 

documents saved in Word are saved with the .docx extension. Microsoft Word can 

be used for the following purposes − 

 To create business documents having various graphics including pictures, 

charts, and diagrams. 

 To store and reuse readymade content and formatted elements such as cover 

pages and sidebars. 

 To create letters and letter eads for personal and business purpose. 

 To design different documents such as resumes or invitation cards etc. 

 To create a range of correspondence from a simple office memo to legal 

copies and reference documents. 

 

Following is the basic window which you get when you start the Word 

application.  

 

 



File Tab 

The File tab replaces the Office button from Word 2007. You can click it to check 

the backstage view. This is where you come when you need to open or save files, 

create new documents, print a document, and do other file-related operations. 

Quick Access Toolbar 

This you will find just above the File tab. This is a convenient resting place for 

the most frequently used commands in Word. You can customize this toolbar 

based on your comfort. 

 

Ribbon contains commands organized in three components − 

 Tabs − These appear across the top of the Ribbon and contain groups of 

related commands. Home, Insert, Page Layout are examples of ribbon tabs. 

 Groups − They organize related commands; each group name appears 

below the group on the Ribbon. For example, group of commands related to 

fonts or group of commands related to alignment, etc. 

 Commands − Commands appear within each group as mentioned above. 

Title bar 

This lies in the middle and at the top of the window. Title bar shows the program 

and document titles. 

Rulers 

Word has two rulers - a horizontal ruler and a vertical ruler. The horizontal ruler 

appears just beneath the Ribbon and is used to set margins and tab stops. The 

vertical ruler appears on the left edge of the Word window and is used to gauge 

the vertical position of elements on the page. 

Zoom Control 



Zoom control lets you zoom in for a closer look at your text. The zoom control 

consists of a slider that you can slide left or right to zoom in or out; you can click 

the + buttons to increase or decrease the zoom factor. 

View Buttons 

The group of five buttons located to the left of the Zoom control, near the bottom 

of the screen, lets you switch through the Word's various document views. 

 Print Layout view − This displays pages exactly as they will appear when 

printed. 

 Full Screen Reading view − This gives a full screen view of the document. 

 Web Layout view − This shows how a document appears when viewed by 

a Web browser, such as Internet Explorer. 

 Outline view − This lets you work with outlines established using Word’s 

standard heading styles. 

 Draft view − This formats text as it appears on the printed page with a few 

exceptions. For example, headers and footers aren't shown. Most people 

prefer this mode. 

Document Area 

This is the area where you type. The flashing vertical bar is called the insertion 

point and it represents the location where text will appear when you type. 

Status Bar 

This displays the document information as well as the insertion point location. 

From left to right, this bar contains the total number of pages and words in the 

document, language, etc. 

You can configure the status bar by right-clicking anywhere on it and by selecting 

or deselecting options from the provided list. 

Moving with Go To Command 

Press the F5 key to use the Go To command. This will display a dialogue box 

where you will have various options to reach to a particular page. 

Normally, we use the page number, the line number or the section number to go 

directly to a particular page and finally press the Go To button. 



 

Saving New Document 

Once you are done with typing in your new Word document, it is time to save 

your document to avoid losing work you have done on a Word document. 

Following are the steps to save an edited Word document − 

Step 

1 − 

Click 

the File 

tab and 

select 

the Sav

e 

As opti

on. 

 

 

  



Step 2 − Select a folder where you will like to save the document, Enter the file 

name which you want to give to your document and Select the Save As option, by 

default it is the .docx format. 

 

 

Step 3 − finally, click on the Save button and your document will be saved with 

the entered name in the selected folder. 

 

Opening New Document 

A new, blank document always opens when you start Microsoft Word. Suppose 

you want to start another new document while you are working on another 

document, or you closed an already opened document and want to start a new 

document. Here are the steps to open a new document − 



Step 1 − Click the File tab and select the New option. 

 

 

 

Step 2 − When you select the New option from the first column, it will display a 

list of templates in the second column. Double-click on the Blank document; this 

is the first option in the template list. We will discuss the other templates available 

in the list in the following chapters. 

You should have your blank document as shown below. The document is now 

ready for you to start typing your text. 



 

Opening Existing Document 

There may be a situation when you open an existing document and edit it partially 

or completely. Follow the steps given below to open an existing document − 

Step 1 − Click the File tab and select the Open option. 

 

Step 2 − This will display the following file Open dialog box. This lets you 

navigate through different folders and files, and also lets you select a file which 

you want to open. 



 

Step 3 − Finally, locate and select a file which you want to open and click the 

small triangle available on the Open button to open the file. You will have 

different options to open the file, but simply use the Open option. 

 

Text Alignments in Word 

Left-Aligned Text 



A paragraph's text is left aligned when it is aligned evenly along the left margin. 

Here is a simple procedure to make a paragraph text left-aligned. 

Step  − Click anywhere on the paragraph you want to align and click the Align 

Text Left button available on the Home tab or simply press the Ctrl + L keys. 

Center Aligned Text 

A paragraph's text will be said center aligned if it is in the center of the left and 

right margins. Here is a simple procedure to make a paragraph text center aligned. 

Step  − Click anywhere on the paragraph you want to align and click 

the Center button available on the Home tab or simply press the Ctrl + E keys. 

Right-Aligned Text 

A paragraph's text is right-aligned when it is aligned evenly along the right 

margin. Here is a simple procedure to make a paragraph text right-aligned. 

Step − Click anywhere on the paragraph you want to align and click the Align 

Text Right button available on the Home tab or simply press the Ctrl + R keys. 

Justified Text 

A paragraph's text is justified when it is aligned evenly along both the left and the 

right margins. Following is a simple procedure to make a paragraph text justified. 

Step  − Click anywhere on the paragraph you want to align and click 

the Justify button available on the Home tab or simply press the Ctrl + J keys. 

When you click the Justify button, it displays four options, justify, justify low, 

justify high and justify medium. You need to select only the justify option. The 

difference between these options is that low justify creates little space between 

two words, medium creates a more space than low justify and high creates 

maximum space between two words to justify the text. 

Create Bullets in Word 

Step 1 − Select a list of text to which you want to assign bullets or numbers. You 

can use any of the text selection method to select the portion of text. 

Step 2 − Click the Bullet Button triangle to display a list of bullets you want to 

assign to the list. You can select any of the bullet style available by simply 

clicking over i 



 

Spacing between Lines 

Following are the simple steps to adjust spacing between two lines of the 

document. 

Step 1 − Select the paragraph or paragraphs for which you want to define spacing. 

You can use any of the text selection method to select the paragraph(s). 

Step 2 − Click the Line and Paragraph Spacing Button triangle to display a list 

of options to adjust space between the lines. You can select any of the option 

available by simply clicking over it. 

 



 

Spacing between Paragraphs 

You can also set distance between two paragraphs. Following are the simple steps 

to set this distance. 

Step 1 − Select the paragraph or paragraphs for which you want to define spacing 

and click the Paragraph Dialog Box launcher available on the Home tab. 

Step 2 − Click the Before spinner to increase or decrease the space before the 

selected paragraph. Similar way, click the After spinner to increase or decrease 

the space after the selected paragraph. Finally, click the OK button to apply the 

changes. 

 

Header and Footer in Word 

Step 1 − Click the Insert tab, and click either the Header button or the Footer 

button that which needs to be added first. Assume you are going to add Header; 

when you click the Header button it will display a list of built-in Headers from 

where you can choose any of the headers by simply clicking on it. 



 

Step 2 − Once you select any of the headers, it will be applied to the document in 

editable mode and the text in your document will appear dimmed, Header and 

Footer buttons appear on the Ribbon and a Close Header and Footer button will 

also appear at the top-right corner. 



 

Add Page Numbers 

Step 1 − Click the Insert tab, and click the Page Number button available in the 

header and footer section. This will display a list of options to display the page 

number at the top, bottom, current position etc. 



 

Step 2 − When you move your mouse pointer over the available options, it 

displays further styles of page numbers to be displayed. For example, when I take 

the mouse pointer at the Bottom of Page option it displays the following list of 

styles. 

 

 

 

 

 

 

 

 

 

 

 



Remove Page Numbers 

Step 1 − Click the Insert tab, and click the Page Number button available in the 

header and footer section. This will display a list of options to display page number 

at the top, bottom, current position, etc. At the bottom, you will have the Remove 

Page Numbers option. Just click this option and it will delete all the page numbers 

set in your document. 

 

Insert Page Breaks 

Step 1 − Bring your insertion point immediately before the text that has to 

appear on a new page. 

Step 2 − Click the Insert tab, and click the Page Break button available in the 

Pages group. 



 

Word inserts a page break and moves all text after the page break onto a new 

page. You can also use the Ctrl + Enter keys to create a page break at the pointed 

location. 

 

Delete a Page Break 

Just put the insertion point on the previous page of the page break that needs to be 

deleted. Press the Delete key multiple times until both the pages get merged. 



Page Orientation 

Step 1 − Open the Word document the orientation of which needs to be changed. 

By default, orientation will be Portrait Orientation as shown below. 

 

Step 2 − Click the Page Layout tab, and click the Orientation button available in 

the Page Setup group. This will display an Option Menu having both the options 

(Portrait & Landscape) to be selected. 



 

Step 3 − Click any of the options you want to set to orientation. Because our page 

is already in portrait orientation, we will click the Landscape option to change my 

orientation to landscape orientation. 

 

Create a Table 

Step 1 − Click the Insert tab followed by the Table button. This will display a 

simple grid as shown below. When you move your mouse over the grid cells, it 

makes a table in the table that appears in the document. You can make your table 

having the desired number of rows and columns. 



 

Step 2 − Click the square representing the lower-right corner of your table, which 

will create an actual table in your document and Word goes in the table design 

mode. The table design mode has many options to work with as shown below. 

 

Delete a Table 

Following are the simple steps to delete an existing table from a word document. 

Step 1 − Click anywhere in the table you want to delete. 



Step 2 − Click the Layout tab, and click the Delete Table option under 

the Delete Table Button to delete the complete table from the document along 

with its content. 

 

Merging Cells 

Step 1 − Bring your mouse pointer position inside the first cell that you want to 

merge. Now press the Shift key and click the cells around the cell which you want 

to merge into the first cell. This will highlight the cells which you click and they 

will be ready to be merged. 



 

Step 2 − Now click the Layout tab and then click the Merge Cells button which 

will merge all the selected cells 

 

 

Split a Cell 

Step 1 − Bring your mouse pointer position inside the cell that has to be divided 

into multiple cells. 



 

Step 2 − Now click the Layout tab and then click the Split Cells button; this will 

display a dialog box asking for the number of rows and columns to be created 

from the selected cell. 

 

Step 3 − Select the desired number of rows and columns that have to go into the 

resultant cell and finally click the OK button to apply the result. 



 

 

Mail Merge – 

1. Open an existing Word document, or create a new one. 

2. From the Mailings tab, click the Start Mail Merge command and 

select Step-by-Step Mail Merge Wizard from the drop-down menu. 

 

  



The Mail Merge pane will appear and guide you through the six main steps to 

complete a merge. The following example demonstrates how to create a form letter 

and merge the letter with a recipient list. 

Step 1: 

From the Mail Merge task pane on the right side of the Word window, choose 

the type of document you want to create. In our example, we'll select Letters. 

Then click Next: Starting document to move to Step 2. 

 

Step 2: 

 Select Use the current document, then click Next: Select 

recipients to move to Step 3. 



 

Step 3: 

Now you'll need an address list so Word can automatically place each address into 

the document. The list can be in an existing file, such as an Excel workbook, or 

you can type a new address list from within the Mail Merge Wizard. 

1. Select Use an existing list, then click Browse to select the file. 



 

2.Locate your file, then click Open. 

 

3.If the address list is in an Excel workbook, select the worksheet that contains the 

list, then click OK. 



 

4.In the Mail Merge Recipients dialog box, you can check or uncheck each box 

to control which recipients are included in the merge. By default, all recipients 

should be selected. When you're done, click OK. 

 

5.Click Next: Write your letter to move to Step 4. 



 

Step 4: 

Now you're ready to write your letter. When it's printed, each copy of the letter will 

basically be the same; only the recipient data (such as the name and address) will 

be different. You'll need to add placeholders for the recipient data so Mail Merge 

knows exactly where to add the data. 

To insert recipient data: 

1. Place the insertion point in the document where you want the 

information to appear. 



 

2. Choose one of the placeholder options. In our example, we'll 

select Address block. 

 

3. Depending on your selection, a dialog box may appear with various 

customization options. Select the desired options, then click OK. 



 

4. A placeholder will appear in your document (for 

example, «AddressBlock»). 

 

5. Add any other placeholders you want. In our example, we'll add 

a Greeting line placeholder just above the body of the letter. 



 

6. When you're done, click Next: Preview your letters to move to Step 

5. 

 

For some letters, you'll only need to add an Address block and Greeting line. But 

you can also add more placeholders (such as recipients' names or addresses) in the 

body of the letter to personalize it even further. 

Step 5: 

1. Preview the letters to make sure the information from the recipient list 

appears correctly in the letter. You can use the left and right scroll 

arrows to view each version of the document. 



 

2. If everything looks correct, click Next: Complete the merge to move 

to Step 6. 

 

 

After completing select Finish and merge. Select the email id and 

send the mail . 

 



MS Excel  

.xls extension 

The following basic window appears when you start the excel application. Let us now 

understand the various important parts of this window.

 

 

 

Sheet Area 

The area where you enter data. The flashing vertical bar is called the insertion 

point and it represents the location where text will appear when you type. 

 

Row Bar 

Rows are numbered from 1 onwards and keeps on increasing as you keep entering 

data. Maximum limit is 1,048,576 rows. 

Column Bar 



Columns are numbered from A onwards and keeps on increasing as you keep 

entering data. After Z, it will start the series of AA, AB and so on. Maximum limit 

is 16,384 columns. 

  

CCrreeaattee WWoorrkksshheeeett iinn EExxcceell  

Three new blank sheets always open when you start Microsoft Excel. Below steps 

explain you how to create a new worksheet if you want to start another new 

worksheet while you are working on a worksheet, or you closed an already opened 

worksheet and want to start a new worksheet. 

Step 1 − Right Click the Sheet Name and select Insert option. 

 

Step 2 − Now you'll see the Insert dialog with select Worksheet option as selected 

from the general tab. Click the Ok button. 



 

Charts 

A chart is a visual representation of numeric values. Charts (also known as 

graphs) have been an integral part of spreadsheets. Charts generated by early 

spreadsheet products were quite crude, but thy have improved significantly over 

the years. Excel provides you with the tools to create a wide variety of highly 

customizable charts. Displaying data in a well-conceived chart can make your 

numbers more understandable. Because a chart presents a picture, charts are 

particularly useful for summarizing a series of numbers and their 

interrelationships. 

Types of Charts 

There are various chart types available in MS Excel as shown in the below screen-

shot. 



 

 Column − Column chart shows data changes over a period of time or 

illustrates comparisons among items. 

 Bar − A bar chart illustrates comparisons among individual items. 

 Pie − A pie chart shows the size of items that make up a data series, 

proportional to the sum of the items. It always shows only one data series 

and is useful when you want to emphasize a significant element in the data. 

 Line − A line chart shows trends in data at equal intervals. 

 Area − An area chart emphasizes the magnitude of change over time. 

 X Y Scatter − An xy (scatter) chart shows the relationships among the 

numeric values in several data series, or plots two groups of numbers as one 

series of xy coordinates. 

 Stock − This chart type is most often used for stock price data, but can also 

be used for scientific data (for example, to indicate temperature changes). 

 Surface − A surface chart is useful when you want to find the optimum 

combinations between two sets of data. As in a topographic map, colors and 

patterns indicate areas that are in the same range of values. 

 Doughnut − Like a pie chart, a doughnut chart shows the relationship of 

parts to a whole; however, it can contain more than one data series. 

 Bubble − Data that is arranged in columns on a worksheet, so that x values 

are listed in the first column and corresponding y values and bubble size 

values are listed in adjacent columns, can be plotted in a bubble chart. 



 Radar − A radar chart compares the aggregate values of a number of data 

series. 

Creating Chart 

To create charts for the data by below mentioned steps. 

 Select the data for which you want to create the chart. 

 Choose Insert Tab » Select the chart or click on the Chart group to see 

various chart types. 

 Select the chart of your choice and click OK to generate the chart. 

 

Editing Chart 

You can edit the chart at any time after you have created it. 

 You can select the different data for chart input with Right click on chart » 

Select data. Selecting new data will generate the chart as per the new data, 

as shown in the below screen-shot. 



 

 You can change the X axis of the chart by giving different inputs to X-axis 

of chart. 

 You can change the Y axis of chart by giving different inputs to Y-axis of 

chart. 

Pivot Tables 

A pivot table is essentially a dynamic summary report generated from a database. 

The database can reside in a worksheet (in the form of a table) or in an external 

data file. A pivot table can help transform endless rows and columns of numbers 

into a meaningful presentation of the data. Pivot tables are very powerful tool for 

summarized analysis of the data. 

Pivot tables are available under Insert tab » PivotTable dropdown » 

PivotTable. 

Pivot Table Example 

Now, let us see Pivot table with the help of example. Suppose you have huge data 

of voters and you want to see the summarized data of voter Information per party, 

then you can use the Pivot table for it. Choose Insert tab » Pivot Table to insert 

pivot table. MS Excel selects the data of the table. You can select the pivot table 

location as existing sheet or new sheet. 



 

This will generate the Pivot table pane as shown below. You have various options 

available in the Pivot table pane. You can select fields for the generated pivot 

table. 

 

 Column labels − A field that has a column orientation in the pivot table. 

Each item in the field occupies a column. 

 Report Filter − You can set the filter for the report as year, then data gets 

filtered as per the year. 

 Row labels − A field that has a row orientation in the pivot table. Each item 

in the field occupies a row. 



 Values area − The cells in a pivot table that contain the summary data. 

Excel offers several ways to summarize the data (sum, average, count, and 

so on). 

After giving input fields to the pivot table, it generates the pivot table with the 

data as shown below. 

 

 

Validation Criteria 

To specify the type of data allowable in a cell or range, follow the steps below, 

which shows all the three tabs of the Data Validation dialog box. 

 Select the cell or range. 

 Choose Data » Data Tools » Data Validation. Excel displays its Data 

Validation dialog box having 3 tabs settings, Input Message and Error alert. 

Settings Tab 

Here you can set the type of validation you need. Choose an option from the 

Allow drop-down list. The contents of the Data Validation dialog box will change, 

displaying controls based on your choice. 

 Any Value − Selecting this option removes any existing data validation. 

 Whole Number − The user must enter a whole number.For example, you 

can specify that the entry must be a whole number greater than or equal to 

50. 



 Decimal − The user must enter a number. For example, you can specify that 

the entry must be greater than or equal to 10 and less than or equal to 20. 

 List − The user must choose from a list of entries you provide. You will 

create drop-down list with this validation. You have to give input ranges 

then those values will appear in the drop-down. 

 Date − The user must enter a date. You specify a valid date range from 

choices in the Data drop-down list. For example, you can specify that the 

entered data must be greater than or equal to January 1, 2013, and less than 

or equal to December 31, 2013. 

 Time − The user must enter a time. You specify a valid time range from 

choices in the Data drop-down list. For example, you can specify that the 

entered data must be later than 12:00 p.m. 

 Text Length − The length of the data (number of characters) is limited. You 

specify a valid length by using the Data drop-down list. For example, you 

can specify that the length of the entered data be 1 (a single alphanumeric 

character). 

 Custom − To use this option, you must supply a logical formula that 

determines the validity of the user’s entry (a logical formula returns either 

TRUE or FALSE). 

 

 



 

Macros in MS Excel 

Macros enable you to automate almost any task that you can undertake in Excel 

2010. By using macro recorder from View Tab » Macro Dropdown to record 

tasks that you perform routinely, you not only speed up the procedure 

considerably but you are assured that each step in a task is carried out the same 

way each and every time you perform a task. 

To view macros choose View Tab » Macro dropdown. 

 

Macro Options 

View tab contains a Macros command button to which a dropdown menu 

containing the following three options. 

 View Macros − Opens the Macro dialog box where you can select a macro 

to run or edit. 

 Record Macro − Opens the Record Macro dialog box where you define the 

settings for your new macro and then start the macro recorder; this is the 

same as clicking the Record Macro button on the Status bar. 

 Use Relative References − Uses relative cell addresses when recording a 

macro, making the macro more versatile by enabling you to run it in areas 

of a worksheet other than the ones originally used in the macro’s recording. 

 



Creating Macros 

You can create macros in one of two ways − 

 Use MS Excel’s macro recorder to record your actions as you undertake 

them in a worksheet. 

 Enter the instructions that you want to be followed in a VBA code in the 

Visual Basic Editor. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 

Microsoft Access 

.accdb Extension 

Microsoft Access stores information which is called a database. To use MS 

Access, you will need to follow these four steps − 

 Database Creation − Create your Microsoft Access database and specify 

what kind of data you will be storing. 

 Data Input − After your database is created, the data of every business day 

can be entered into the Access database. 

 Query − This is a fancy term to basically describe the process of retrieving 

information from the database. 

 Report (optional) − Information from the database is organized in a nice 

presentation that can be printed in an Access Report. 

MS Access uses “objects" to help the user list and organize information, as well as 

prepare specially designed reports. When you create a database, Access offers you 

Tables, Queries, Forms, Reports, Macros, and Modules. Databases in Access are 

composed of many objects but the following are the major objects − 

 Tables 

 Queries 

 Forms 

 Reports 

Together, these objects allow you to enter, store, analyze, and compile your data. 

Here is a summary of the major objects in an Access database; 

Table 

Table is an object that is used to define and store data. When you create a new 

table, Access asks you to define fields which is also known as column headings. 

 Each field must have a unique name, and data type. 

 Tables contain fields or columns that store different kinds of data, such as a 

name or an address, and records or rows that collect all the information 

about a particular instance of the subject, such as all the information about a 

customer or employee etc. 



 You can define a primary key, one or more fields that have a unique value 

for each record, and one or more indexes on each table to help retrieve your 

data more quickly. 

Query 

An object that provides a custom view of data from one or more tables. Queries 

are a way of searching for and compiling data from one or more tables. 

 Running a query is like asking a detailed question of your database. 

 When you build a query in Access, you are defining specific search 

conditions to find exactly the data you want. 

 In Access, you can use the graphical query by example facility or you can 

write Structured Query Language (SQL) statements to create your queries. 

 You can define queries to Select, Update, Insert, or Delete data. 

 You can also define queries that create new tables from data in one or more 

existing tables. 

Form 

Form is an object in a desktop database designed primarily for data input or 

display or for control of application execution. You use forms to customize the 

presentation of data that your application extracts from queries or tables. 

 Forms are used for entering, modifying, and viewing records. 

 The reason forms are used so often is that they are an easy way to guide 

people toward entering data correctly. 

 When you enter information into a form in Access, the data goes exactly 

where the database designer wants it to go in one or more related tables. 

Report 

Report is an object in desktop databases designed for formatting, calculating, 

printing, and summarizing selected data. 

 You can view a report on your screen before you print it. 

 If forms are for input purposes, then reports are for output. 

 Anything you plan to print deserves a report, whether it is a list of names 

and addresses, a financial summary for a period, or a set of mailing labels. 



 Reports are useful because they allow you to present components of your 

database in an easy-to-read format. 

 You can even customize a report's appearance to make it visually appealing. 

 Access offers you the ability to create a report from any table or query. 

 

Other MS Access Objects 

Let us now take a look at other MS Access objects. 

Macro 

This object is a structured definition of one or more actions that you want Access 

to perform in response to a defined event. An Access Macro is a script for doing 

some job. For example, to create a button which opens a report, you could use a 

macro which will fire OpenReport action. 

 You can include simple conditions in macros to specify when one or more 

actions in the macro should be performed or skipped. 

 You can use macros to open and execute queries, to open tables, or to print 

or view reports. 

 You can also run other macros or Visual Basic procedures from within a 

macro. 

 Data macros can be attached directly to table events such as inserting new 

records, editing existing records, or deleting records. 

 Data macros in web apps can also be stand-alone objects that can be called 

from other data macros or macro objects. 

Module 

Module is an object in desktop databases containing custom procedures that you 

code using Visual Basic. Modules provide a more discrete flow of actions and 

allow you to trap errors. 

 Everything that can be done in a macro can also be done in a module, but 

you don't get the macro interface that prompts you what is needed for each 

action. 



 Modules are far more powerful, and are essential if you plan to write code 

for a multi-user environment, because macros cannot include error 

handling. 

 Modules can be standalone objects containing functions that can be called 

from anywhere in your application, or they can be directly associated with a 

form or a report to respond to events on the associated form or report. 

 

Create Blank Database 

Sometimes database requirements can be so specific that using and modifying the 
existing templates requires more work than just creating a database from scratch. In 
such case, we make use of blank database. 

Step 1 − Let us now start by opening MS Access. 

 

Step 2 − Select Blank desktop database. Enter the name and click the Create button. 



 

Step 3 − Access will create a new blank database and will open up the table which is 
also completely blank. 

 

Data Types 
 

Type of Data Description Size 
Short Text Text or combinations of text and 

numbers, including numbers that do not 
require calculating (e.g. phone numbers). 

Up to 255 characters. 

Long Text Lengthy text or combinations of text and 
numbers. 

Up to 63, 999 characters. 

Number Numeric data used in mathematical 
calculations. 

1, 2, 4, or 8 bytes (16 
bytes if set to Replication 



ID). 

Date/Time Date and time values for the years 100 
through 9999. 

8 bytes 

Currency Currency values and numeric data used 
in mathematical calculations involving 
data with one to four decimal places. 

8 bytes 

AutoNumber A unique sequential (incremented by 1) 
number or random number assigned by 
Microsoft Access whenever a new record 
is added to a table. 

4 bytes (16 bytes if set to 
Replication ID). 

Yes/No Yes and No values and fields that 
contain only one of two values (Yes/No, 
True/False, or On/Off). 

1 bit. 

Attachment Files, such as digital photos. Multiple files 
can be attached per record. This data 
type is not available in earlier versions of 
Access. 

Up to about 2 GB. 

OLE objects OLE objects can store pictures, audio, 
video, or other BLOBs (Binary Large 
Objects) 

Up to about 2 GB 

Hyperlink Text or combinations of text and 
numbers stored as text and used as a 
hyperlink address. 

Up to 8,192 (each part of 
a Hyperlink data type can 
contain up to 2048 
characters). 

Lookup Wizard 
The Lookup Wizard entry in the Data 
Type column in the Design view is 
not actually a data type. When you 
choose this entry, a wizard starts to 
help you define either a simple or 
complex lookup field. 

A simple lookup field uses the 
contents of another table or a value 
list to validate the contents of a 
single value per row. A complex 
lookup field allows you to store 
multiple values of the same data 
type in each row. 

 

Dependent on the data 
type of the lookup field 

Calculated 
You can create an expression that 
uses data from one or more fields. 
You can designate different result 
data types from the expression. 

You can create an 
expression that uses data 
from one or more fields. 
You can designate 
different result data types 
from the expression. 

 



Create Tables 
When you create a database, you store your data in tables. Because other database 

objects depend so heavily on tables, you should always start your design of a 

database by creating all of its tables and then creating any other object. Before you 

create tables, carefully consider your requirements and determine all the tables that 

you need. 

This is where we left things off. We created the database and then Access 

automatically opened up this table-one-datasheet view for a table. 

 

Once all the fields are added, click the Save icon. 

You will now see the Save As dialog box, where you can enter a table name for the 
table. 

 

Enter the name of your table in the Table Name field. Here the tbl prefix stands for 
table. Let us click Ok and you will see your table in the navigation pane. 

 

Table Design View 

As we have already created one table using Datasheet View. We will now create 
another table using the Table Design View. We will be creating the following fields in 
this table. These tables will store some of the information for various book projects. 



 

 

to make ProjectID a primary key for this table, so let us select ProjectID and click 
on Primary Key option in the ribbon. 

 

Add some data into your tables by opening the Access database we have created. 



 

Select the Views → Datasheet View option in the ribbon and add some data as shown 
in the following screenshot. 

 

 

Create Select Query 



If you want to review data from only certain fields in a table, or review data from 
multiple tables simultaneously or maybe just see the databased on certain criteria, you 
can use the Select query. Let us now look into a simple example in which we will 
create a simple query which will retrieve information from tblEmployees table. Open 
the database and click on the Create tab. 

 

Click Query Design. 

 

In the Tables tab, on the Show Table dialog, double-click the tblEmployees table and 
then Close the dialog box. 



 

In the tblEmployees table, double-click all those fields which you want to see as result 
of the query. Add these fields to the query design grid as shown in the following 
screenshot. 

 

Now click Run on the Design tab, then click Run. 



 

The query runs, and displays only data in those fields which is specified in the query. 

In MS Access and other DBMS systems, queries can do a lot more than just displaying 
data, but they can actually perform various actions on the data in your database. 

 Action queries are queries that can add, change, or delete multiple records at 
one time. 

 The added benefit is that you can preview the query results in Access before you 
run it. 

 Microsoft Access provides 4 different types of Action Queries − 

o Append 

o Update 

o Delete 

o Make-table 

 An action query cannot be undone. You should consider making a backup of any 
tables that you will update by using an update query. 

Create an Append Query 

You can use an Append Query to retrieve data from one or more tables and add that 
data to another table. Let us create a new table in which we will add data from 
the tblEmployees table. This will be temporary table for demo purpose. 



Let us call it TempEmployees and this contains the fields as shown in the following 
screenshot. 

 

 

In the Tables tab, on the Show Table dialog box, double-click on 
the tblEmployees table and then close the dialog box. Double-click on the field you 
want to be displayed. 



 

Let us run your query to display the data first. 

 

Now let us go back to Query design and select the Append button. 



 

In the Query Type, select the Append option button. This will display the following 
dialog box. 

 

Select the table name from the drop-down list and click Ok. 



 

In the Query grid, you can see that in the Append To row all the field are selected by 
default except Address1. This because that Address1 field is not available in 
the TempEmployee table. So, we need to select the field from the drop-down list. 

 

Let us look into the Address field. 



 

Let us now run your query and you will see the following confirmation message. 

 

Click Yes to confirm your action. 

 

When you open the TempEmployee table, you will see all the data is added from the 
tblEmployees to the TempEmployee table. 

 

 



Create an Update Query 

You can use an Update Query to change the data in your tables, and you can use an 
update query to enter criteria to specify which rows should be updated. An update 
query provides you an opportunity to review the updated data before you perform the 
update. Let us go to the Create tab again and click Query Design. 

 

In the Tables tab, on the Show Table dialog box, double-click on 
the tblEmployees table and then close the dialog box. 

 

On the Design tab, in the Query Type group, click Update and double-click on the field 
in which you want to update the value. Let us say we want to update the FirstName of 
“Rex” to “Max”. 



 

In the Update row of the Design grid, enter the updated value and in Criteria row add 
the original value which you want to be updated and run the query. This will display the 
confirmation message. 

 

Click Yes and go to Datasheet View and you will see the first record — FirstName is 
updated to “Max” now. 

 



Create a Delete Query 

You can use a delete query to delete data from your tables, and you can use a delete 
query to enter criteria to specify which rows should be deleted. A Delete Query 
provides you an opportunity to review the rows that will be deleted before you perform 
the deletion. Let us go to the Create tab again and click Query Design. 

 

In the Tables tab on the Show Table dialog box, double-click the tblEmployees table 
and then close the dialog box. 

 

On the Design tab, in the Query Type group, click Delete and double-click on 
the EmployeeID. 



 

In the Criteria row of the Design Grid, type 11. Here we want to delete an employee 
whose EmployeeID is 11. 

 

Let us now run the query. This query will display the confirmation message. 

 



Click Yes and go to your Datasheet View and you will see that the specified employee 
record is deleted now. 

 

Create a Make Table Query 

You can use a make-table query to create a new table from data that is stored in other 
tables. Let us go to the Create tab again and click Query Design. 

 

In the Tables tab, on the Show Table dialog box, double-click the tblEmployees table 
and then close the dialog box. 



 

Select all those fields which you want to copy to another table. 

 

In the Query Type, select the Make Table option button. 



 

You will see the following dialog box. Enter the name of the new table you want to 
create and click OK. 

 

Now run your query. 



 

You will now see the following message. 

 

Click Yes and you will see a new table created in the navigation pane. 



 

 

 

Creating Forms 

There are a few methods you can use to create forms in Access. For this, open your 
Database and go to the Create tab. In the Forms group, in the upper right-hand corner 
you will see the Form Wizard button. 



 

Click on that button to launch the Form Wizard. 

On this first screen in the wizard, you can select fields that you want to display on your 
form, and you can choose from fields from more than one table or a query. 

Let us assume we want to simply have a quick form that we are going to use for data 
entry for our employee information. 

From Tables/Queries drop-down list, select tblEmployees table. Click on the double 
arrow to move all the fields at once. 



 

Let us just leave it with that one table, and click Next. 

 

The following screen in the Form Wizard will ask for the layout that we would like for 
our form. We have columnar, tabular, datasheet and justified layouts. We will 
choose the columnar layout here and then click Next. 



 

In the following screen, we need to give a title for our form. Let us call 
it frmEmployees. 

Once you have given your form a title, you can open the form to see what that form 
looks like, or you can begin entering information into your table. Or you can choose the 
option to modify the form's design. Let us choose the first option to open the form to 
view or enter information and click Finish. 



 

Now, take a look at the following screenshot. This is what your form looks like. This is a 
single item form, meaning one record is displayed at a time and further down you can 
see the navigation buttons, which is telling us that this is displaying the record 1 of 9. If 
you click on that button then, it will move to the next record. 

 

If you want to jump to the very last record in that form or that table, you can use the 
button right beside that right arrow, the arrow with a line after it, that's the last record 
button. If you want to add new employee information, go to the end of this records and 



then after 9 records you will see a blank form where you can begin entering out the 
new employee's information. 

 
 

This is one example of how you can create a form using the Form Wizard. Let us now 
close this form and go to the Create tab. Now we will create a slightly more 
complicated form using Wizard. Click the Form Wizard and this time, we will choose 
fields from a couple of different tables. 

In this Form Wizard, let us choose tblProjects for Tables/Queries, and select a few 
Available Fields such as ProjectID, ProjectName, ProjectStart, and ProjectEnd. These 
fields will now move to Selected Fields. 

 
 



Now select tblTasks for Tables/Queries and send over the TaskID, ProjectID, 
TaskTitle, StartDate, DueDate and PercentComplete. Click Next. 

 

 

 

Here, we want to retrieve data from a couple of different objects. We can also choose 
from options on how we want to arrange our form. If we want to create a flat form, we 
can choose to arrange by tblTasks, which will create that single form, with all the fields 
laid out in flat view as shown above. 

However, if we want to create a hierarchical form based on that one-to-many 
relationship, we can choose to arrange our data by tblProjects. 



 

In the above window, we have the option to include a subform for tblTasks, or we can 
make that a linked form. This linked form is where tblProjects will have a button that will 
launch that second form filtered to the project that we have selected in that underlying 
projects form. Let us now select the Form with subform(s), and then click Next. 

In the following screen, you can choose a layout for your subform. The Datasheet View 
gets selected by default. The Datasheet View is similar to Table View. Now, click Next. 

 

In the following screen, you need to provide a name for your forms. Enter the name 
you want and click Finish. 



 

Access will give you a preview of what your form looks like. On top, you have the 
controls on your main form, which is from our Projects table. As you go down, you will 
see a subform. It's like a form within a form 

 

 

  



 

MS PowerPoint 

.ppt extension 

 

PowerPoint offers a host of tools that will aid you in creating a presentation. These tools 
are organized logically into various ribbons in PowerPoint. The table below describes 
the various commands you can access from the different menus. 

 



Menu Category Ribbon Commands 

Home Clipboard functions, manipulating slides, fonts, paragraph 
settings, drawing objects and editing functions. 

Insert Insert tables, pictures, images, shapes, charts, special texts, 
multimedia and symbols. 

Design Slide setup, slide orientation, presentation themes and 
background. 

Transitions Commands related to slide transitions. 

Animations Commands related to animation within the individual slides. 

Slide Show Commands related to slideshow set up and previews. 

Review Proofing content, language selection, comments and 
comparing presentations. 

View Commands related to presentation views, Master slides, color 
settings and window arrangements. 

 

To add new slides in an existing presentation. Here are the steps that allow you to 
insert a new slide in the deck − 

Step 1 − Right-click in the Navigation Pane under any existing slide and click on 
the New Slide option. 



 

Step 2 − The new slide is inserted. You can now change the layout of this slide to suit 
your design requirements. 

 



Step 3 − To change the slide layout, right-click on the newly inserted slide and go to 
the Layout option where you can choose from the existing layout styles available to 
you. 

 
 

 

You can follow the same steps to insert a new slide in between existing slides or at the 
end on the slide list. 

When we insert a new slide, it inherits the layout of its previous slide with one 
exception. If you are inserting a new slide after the first slide (Title slide), the 
subsequent slide will have the Title and Content layout. 

You will also notice that if you right-click in the first step without selecting any slide the 
menu options you get are different, although you can insert a new slide from this menu 
too. 



 

 


